PDS:Getting Started With OptiTex PDS

From OptitexHelpEn
Jump to: navigation, search

Contents

Getting Started

Learning The Screen (Interface)

Getting started with OptiTex™ is simple. To begin, let's familiarize ourselves with the screen that we will be using. The layout of this screen is called an interface. We will now explore it:

1. Image of the user interface in OptiTex version 10

Main Menu

1.The Main Menu appears on the top of the screen

At the top of the screen, you find the Main Menu. The menus contained in the Main Menu are often referred as the Menus. They allow you to perform the operations you need in order to draft, edit, change, save, plot, and cut your patterns. In general, the menus contain more advanced tools or less commonly used ones, as opposed to the tools you will find in the toolbars and toolbox.

Icon Toolbars

2. Example of a toolbar

Beneath the Main Toolbar, you find a number of icon toolbars, designed for your convenience. Each icon represents a tool that can be used for working on your pattern(s).

Pieces Window

3. The Pieces window displays all the pattern pieces in the file

The Pieces Window is located below the Icon toolbars. This window displays all the pattern pieces that exist in a particular style. Once we begin working on a pattern, all the pattern pieces appear in this window, along with the name of each piece and the style information.

Working Area

In the center of the screen, there is a large blank rectangle. This is your Working Area. When you select a pattern, the pattern pieces are spread out across the Working Area. Here you can make all changes, and create and draft your pattern pieces. If you do not see the pattern pieces in your working area, you can select the pieces you want to work on from the Pieces Window. Alternatively, you can choose "All to working area" from the Edit menu. Doing so will bring all the pattern pieces to your Working Area.

Working Area

Advanced Draft Tool

In the bottom corner of the Working Area, there are four icons that you can use when creating pieces, drafting, moving, etc. These icons are visible even before you have created a piece, but only become active once a piece is created.

You can see these icons in the yellow highlighted area in the screen below:

Working Area


The following icons are available:

Advanced Draft Tool Interactive.png: Allows you to extend a line according to an angle. For example, 90 degrees. A red line appears showing you the angle as you drag.

Advanced Draft Tool Polar.png: Provides you a horizontal or vertical line according to the point you are standing on.

Advanced Draft Tool Snap.png: Highlights the middle of the segment so you can draw a line exactly in the middle. If the segment is curved, finds a vertical point as well.

Advanced Draft Tool Dynamic.png: Allows you to enter the distance, length and angle so you can get an accurate measurement. This can be used instead of the Point Location dialog.

Rulers and Guide Lines

Rulers can be added to the working area using the View menu.

Rulers

Guide Lines: Click & Hold on the horizontal or vertical ruler and drag guides into the workspace. You can drag Guides around the workspace or remove them by dragging them back to the ruler.
To delete all Guides: Ctrl + Alt + G

To delete a single Guideline: Select Guideline and press delete on your keyboard

Navigation

  • Zooming : Move the Mouse Wheel to Zoom In & Out.
    • Home (or Mouse wheel Button): Brings all the pieces in the working space into a comfortable focus. Clicking the Mouse Wheel produces the same results.
    • Home + Shift : Zooms in on one selected piece in the workspace.
  • Browsing pieces - Page Up/Down
  • Next Piece in Piece Bar - Tab key

The Toolbox

To the left of the Work Area you find a tab labeled Toolbox. In the Toolbox you will find all the tools designed to assist you in the pattern drafting and updating process. For your convenience, the different tools have been divided into groups according to their functionality. When you point to this tab, a box unfolds to reveal 14 tabs: Each of these tabs is labeled according to the functionality of the tools that it contains. For Instance, if we select the General tab from the Toolbox, we find the general tools to assist you with drafting your pattern. The keyboard shortcut for each tool is listed to the right of the tool. If a tool has a keyboard shortcut, you must hold all of the keys down simultaneously in order to invoke the tool.

4. All tools are categorized in the Toolbox according to functionality
5. Click on a Topic to expand the section and display the list of tools

Status Bar

6. The Status Bar provides helpful information on using tools as well as information about working units and the status of pattern pieces

The Status Bar is located at the very bottom of the screen. It provides useful information on how to use the different tools you encounter when using the program. The Status Bar also indicates your current working status, as well as the status of selected pattern pieces.

The Status Bar is divided into two sections.

  • Tool usage – on the left-hand side.
  • Pattern piece status – on the right-hand side.

When you point the cursor at any tool icon, a description of the tool appears in the Tool Usage section of the status bar. After selecting a tool, step-by-step instructions for using the tool appear in the tool usage section of the status bar. Click on a specific pattern piece to view its current status. Please refer to the following example:

8. Look for instructions on tool usage in the Status Bar
9. Follow the steps to optimize tool usage
Once the tool has been selected, the status bar will give step-by-step instructions on the tool usage

The piece status section of the Status Bar indicates the following information:

  • Working units – The units by which the pattern is measured (e.g., centimeters, inches, yards).
  • Piece Locked – indicates if a piece is locked.
  • Cut line – indicates if the piece is programmed according to the cut line or the sew line.

Preferences

10. You can control everything from working units and piece settings to color setting and automatic saving using options in the Preferences window

The Preferences window allows you to control and modify most settings. To access the Preferences window, go to the Tools menu. The Preferences option is at the bottom of the list. Note the different categories on the left-hand side of the window. From this window you can control everything from working units and piece settings to color setting and automatic saving. After making modifications to your screen click Apply to preview the changes. Once you are satisfied, confirm them by clicking OK. You can restore default settings at any time by clicking on Restore all Defaults.

Side Tabs

PDS Getting Started with OptiTex PDS 10.png

Side Tabs are tabs which appear on the sides of your screen and represent windows which have been undocked. Side tabs grant you easy access to a number of different windows in the program. These windows are divided into two categories.

  1. 3D windows – contain tools and properties pertaining to the 3D portion of the program.
  2. Design Assistance Windows – contain properties, measurements, and values of pattern pieces, as well as tools to assist you in the design and drafting process.

If you have not rearranged the window placements, the 3D Side Tabs will appear on the right-hand side of your screen, and the Design Assistance tabs will appear on the left. If one of the 3D windows that you are searching for does not appear on the screen, you can find it under the 3D menu. This will present a list of all 3D windows from which you can select the desired window. Invoke the Design Assistance windows from the View Menu if they are not displayed.

Moving And Docking Windows And Toolbars

11. Point the cursor to the arrow pointing to the side on which you wish to place the tab
12. The windows on your screen will appear either as opened windows or as side tabs

  • To keep a window open while you are working, you must dock the window. To do so, first open the window. Once the window is opened, click on the image of the thumbtack which appears on the upper right-hand side of the window. Click on the thumbtack once so that its tack points down to dock the window.
13. If the thumbtack is lying horizontally, the window is undocked, and will roll up on to the side of the screen once your cursor leaves the window

To make a window appear as a side tab, you must undock the window. To do so, click on the thumbtack that appears in the upper right-hand side of the window. Click on the thumbtack once so that its tack points to the side. Once you have undocked the window, it will roll up and attach to one of the sides of the screen.

To reposition a toolbar, first locate the toolbar handle. The toolbar handle is a four-hold handle found on the extreme left-hand side of each toolbar. Click on the toolbar handle, and the cursor turns into a 4 arrow moving tool. In this state, you can drag the toolbar to any location on your screen.

To reposition a window, you must first make sure that the window is docked. Place the cursor anywhere along the bar on the top of the window where the window name is indicated, then drag the window to the desired location. To make the window appear as a side tab on one side of the screen, simply drag the window to the center of the screen. Four arrows will appear, each pointing to a different side of the screen. Without releasing the mouse, drag the cursor and place it on top of the arrow that is pointing to the side of the screen on which you wish to place the tab. Please see the following example:

General Workflow

The first step in getting started with the OptiTex program is to decide what type of pattern you wish to work on. You can Digitize A Paper Pattern, select a Preexisting OptiTex Pattern, Draft a new pattern using the Draft tool, or make changes to a Pattern Which Was Created Using Another CAD Software Program.
Once you have selected the type of pattern that you are going to be working with, and have opened the pattern in the OptiTex software, you are ready for step two, which is Drafting And Making Changes To The Pattern . After you have finished drafting the pattern, you can test the pattern by virtually sewing it onto a 3-dimensional model. This allows you to view the pattern as a completed garment; you can test the fit, the drape, and the look of the garment. When the patterns are ready , save the file. Saving the file allows you to open it on the marker program, to plot it out using you printer or plotter, to cut it with your automatic cutter, load it to the Modulate program, or export it to any supported format.


Basic Rules for using PDS

Points in the Program

  • Points in the program:

Each line in the program runs between two points. The characteristics of a line (whether it appears as a straight line or a curved one) are defined by the points which support it.

17.
18.

Work in a Clockwise Motion

While you are drafting or making changes to a pattern piece, it is important to keep in mind that the program operates in a clockwise motion. When you select a number of points, make sure that you proceed from the first point you select in a clockwise direction:

20.
21. The selected segment is highlighted
22.
23.

Properties Window

19. At the bottomof the screen, there is a help panel

The Properties window allows you to change the properties of a pattern piece, point, notch, or internal element. In this window you can change the names and properties of a selected element. Click on the element you wish to update, and the properties will change to reflect the properties of the element you have selected. The Properties window changes to reflect either Piece, Point, Dart, or Internal Contour properties, according to the element that you have selected. Double-click on the element you wish to update if you do not see the Properties window clearly. At the bottom of the Properties window you find the Description Panel, which helps you understand the different available properties. Click on any property inside the Properties window to display a brief description of the selected property.

Style Sets

24. Create multiple cut orders from a single style

The Style Sets window is a significant window, which serves two major purposes:

    • Enables you to define the quantity and fabrication for each pattern piece in your style. This comes in handy when a piece needs to be cut more than once, or when you are using a variety of different fabrics.
    • Enables you to select particular pattern pieces to form a sub-style called a Style Set. This comes in handy when you are through creating a style and are ready to place the pattern pieces on a marker. If you do not need all of the pattern pieces to be calculated in the marker, define specific pattern pieces by using the Style Sets window.
25.

The Main style set includes all the pattern pieces. Here you can define the number of times each pattern piece needs to be cut (Cut 1, Cut 2, etc.). Simply enter the information in the Quantity column for each piece. To select the correct fabrication, click on the Material line that appears to the right of each pattern piece. A list of fabrications will drop down; select the correct fabrication for each piece.

To add pieces to a marker style set, name a new style set by clicking on the Add button which appears to the right of the top line labeled Style Sets. Add pattern pieces by clicking on a pattern piece in your work area and then selecting Add Piece to include the piece that you have selected in the marker style set.

Alt Shortcut Key

The Alt key has a major role in the OptiTex program. Tools which allow you to move or rotate pattern pieces, points, or internal elements share the Alt key shortcut. By holding down the Alt key throughout the operation, you invoke a moving Dialog.

X and Y Axis Lines

The first point you draft becomes your reference point, and has the following coordinates: (0, 0). All points or elements that you create have X and Y coordinates relative to the point preceding it and the point following it. Thus, when you create a new point or wish to move an existing point, you do so using these coordinates. Please see the following example, in which the second point has the coordinates (2,3):

[[Image:

Adding a point is always done in relation to pre-existing points, and can be done in one of two ways :

  • In relation to previous and next points using the X and Y Axis line coordinates.
  • In relation to previous and next points using absolute values along an external contour.
  • If you choose to place a point on a segment according to the X and Y coordinates, you must uncheck the Move Along Contour option. The Dialog window will show:
28.


  • If you choose to place the point relative to other points, the option to Move Along Contour must be checked. The Dialog window will show:
29.

In a clockwise motion, the previous point represents the point preceding the point you wish to add. And the next point represents the point which follows the point you wish to add.

  • When you enter a value in the Absolute boxes, you determine the distance from the previous to the next point in the working unit you have selected (centimeters, millimeters, inches etc…).
  • When you enter a value in the Proportion boxes, you calculate the same distance in fractions. For instance, if you wish to place the new point between two existing points, enter 0.5 (representing 1/2) in either of the proportion boxes. The point will then be placed exactly in the middle of the segment between the two points.

Note that in both cases you can choose the type of point you wish to add. You can add a grading point, a curve point and even check both boxes to create a curved grading point.

Opening a Pattern

In order to get started, you must first decide which type of pattern you would like to work on. You can choose from four different options:

  1. Draft a new pattern.
  2. Digitize A Paper Pattern into OptiTex.
  3. Open a preexisting OptiTex file.
  4. Open a file which was created in another Pattern Drafting program (Gerber, Lectra, Investronica, Micro).

Drafting A New Pattern

Create a New filefrom the New command in the File menu. Use the Draft tool or the Make a Piece command to create the basic shape of the pattern. Following the basic rules that were described above, start to shape the pattens and to add internal elements. Use the section to access more information.

Digitizing A Paper Pattern

15. Digitizer Button Information: This menu explains which buttons must be clicked to input specific point information
16. Enter points in a clockwise motion

To import a paper pattern into the OptiTex program, select the Digitize command in the File menu. A new screen representing the Digitizing table will pop up. As you enter your pattern points, you see them on the Digitizer screen. At the bottom of the Digitizer screen, note the list of commands preceded by either a number or a letter. These commands correspond to the buttons that appear on your Digitizer.

From your paper patterns, select a size that represents your Base Size pattern. Use clear tape to tape down the first pattern piece on to the digitizer tablet. Place the digitizing cursor over the first corner of the pattern and press "1" to indicate a grading point or "3" to indicate a non-grading point. Place many curve points along rounded sections in order to insure that rounded lines do in fact appear curved on the screen. To erase a point, press the "C" button. Make sure that you enter the points in a clockwise motion. After entering all pattern points and curved lines, place the digitizer cursor on the last point and press "2" to connect the first point with the last point in a straight line. This will close the piece. Once you have closed the piece you can go back and enter internal points such as dart tips, pleat points, notches and more. When you are through entering the pattern piece information, click "1" to start a new piece. When you have finished digitizing the pieces,click on Done to close the Digitize window and to view the pieces that you have entered, which appear on the piece bar.

Select A Preexisting OptiTex Pattern

To open an existing OptiTex file, simply select the Open command from the File menu; a window is displayed that allows you to browse through your computer files. Double-click on the requested file to invoke the OptiTex program.

Opening A Style Created Using A Different Pattern Drafting Program

Note: CONVERTORS ARE NOT INCLUDED IN THE BASIC OPTITEX PACKAGE.

OptiTex has developed five types of converters. These converters are capable or translating files which were created in different software programs into OptiTex. The converters are compatible with the following programs:

Please click on the program in which your pattern was created for additional information on how to use the proper converter.

In addition to the converters, the Import module handles data exchange between different CAD systems. Use the Import command to load patterns that were saved as DXF, ASTM, NC or other file types.




Note: TAKE THIS INFORMATION FROM STARTING TO USE THE PROGRAM
Personal tools
Marker